Back to overview
Resolved

Authentication provider unstable

Jul 16, 2026 at 8:00am UTC
Affected services
Better Email Platform

Resolved
Jul 16, 2026 at 10:10am UTC

The incident at our provider has been resolved, and we're no longer seeing issues logging in to Better Email.

Created
Jul 16, 2026 at 8:00am UTC

Our authentication provider WorkOS is currently having issues, which is affecting our login services. Users who are not already logged in might have difficulties accessing app.better.email.